Windows 2000 support

Conrad Sallian, Administrator (Posts: 1116)

Jan 31, 2014 10:45:06 am EST

UPDATE: We no longer provide links to download old versions. If you need older versions of Remote Utilities, please request them via a ticket.

Remote Utilities no longer supports Windows 2000. If errors occur when you install the latest version of the Host on the Win2K system, you can download request and try one of the older versions.

However, please note that:

- You use a previous version at your own risk
- We neither provide technical support for previous versions nor fix bugs in them
- Free 10-remote-PC business license does NOT work with versions older than
- The only way to use an old version beyond the 30-day trial period is to purchase a commercial license

P.S. You can connect to an older Host with the latest Viewer though.

Philip Partridge, User (Posts: 2)

Jan 31, 2014 12:32:35 pm EST

Thank you for the prompt response.
That is one plus for LogMeIn then. However, there is a workaround with a little lateral thinking..

If there are any others who have moved to remote Utilities and have this scenario:
If you have a PC running XP on the network, and you can create a Host account of Remote Utilities on that.
You can then use the RDP client to create a connection to the Server.

Not perfect, as you are remotely controlling the Server from a remote control session on a PC on the LAN.

Conrad Sallian, Administrator (Posts: 1116)

Jan 31, 2014 1:08:04 pm EST

Yes, that might work too. Thanks for the recommendation, Philip.

* Website time zone: America/New_York (UTC -4)